Tras instalar Arduide es posible que te hayas encontrado con el problema de que no puedes utilizar esta interfaz con la última versión del software de arduino.

Al seleccionar el directorio donde se encuentra el programa de arduino te muestra un mensaje de error diciendo que no has introducido la ubicación correcta del software de arduino.

arduide-mensaje-error

Para saltarse este error y utilizar la interfaz con la última versión de arduino lo que tenemos que hacer es modificar el nombre de la carpeta del software de arduino y el archivo revisions.txt.

Renombrar la carpeta

Como yo tengo arduino instalado desde los repositorios se encuentra en /usr/share/arduino y para no tener problemas con los enlaces del menú de aplicaciones en caso de usar la interfaz original, lo que hago es crear un enlace simbólico a esa carpeta en ~/.local/share/data/MuPuF.org/"Arduino IDE".

El enlace simbólico lo creo en esa carpeta porque es dónde instala Arduide el software en caso de descargarlo e instalarlo desde la interfaz.

[usuario@equipo ~]$ ln -s /usr/share/arduino ~/.local/share/data/MuPuF.org/"Arduino IDE"/arduino-1.0.2

Si descargaste el software desde la página de arduino y/o no quieres crear un enlace simbólico, lo único que tienes que hacer es cambiar el nombre a la carpeta por arduino-1.0.2.

Editar revisions.txt

El siguiente paso es editar el archivo revisions.txt. Este archivo se encuentra dentro de la carpeta de arduino (en /usr/share/arduino/ en mi caso).

La primera línea de este archivo debe contener algo como esto:

ARDUINO 1.0.3 - 2012.12.10

Debemos sustituir la versión por la 1.0.2 que es la que reconoce Arduide y además debe estar en la primera linea del archivo.

ARDUINO 1.0.2 - 2012.12.10

Ahora al ejecutar el programa ya debería dejarte trabajar con la última versión de arduino. Si no es así asegúrate de haber cambiado el nombre de la carpeta por el correcto y que el archivo revisions.txt está bien editado, después selecciona como ruta de arduino la ubicación donde se encuentre tu carpeta.